Version: 5.x

Supported React Native versions

React Navigation 5 depends on the new hooks API and libraries using androidx. So you'll need to be on at least [email protected]. If you're using Expo, your SDK version should be at least 36.

You also need to make sure that your React Native version is compatible with following libraries:

Please note that the statements above may not be correct for a particular react-native version. If you notice a version that is not working properly, feel free to either file an issue or correct it in this page.